News: Updates

e-Branch

Updated Browser Requirements

You will soon have an exciting updated look and enhanced features when you log on to our convenient e-Branch (upper right corner of PECU’s homepage). In order to better serve our members and ensure your online banking experience and financial information is safe and secure, we ask that you please make sure your internet browsers are updated to meet our minimum system requirements.

Browser Requirements:

  • Google Chrome 37 and later
  • Microsoft Internet Explorer 11 and later
  • Mozilla Firefox 33 and later
  • Safari 9 or later

Important Note: Internet Explorer 10 will no longer work with PECU e-Branch as of August 10, 2017.